MCP/EFIS Opencockpit + PMDG 737NG

Silverstar

CONTROLEUR AERIEN
Messages
23 033
Réactions
3 274
Points
3 501
Tout d'abord on se familiarise bien avec LINDA et SIOC et Les tutoriels sioc de mameloose
Allez c'est parti, je vous montre pour le MCP après ça sera à votre tour si vous avez compris de le faire pour les EFIS

On va sur le site de Opencockpit pour récupérer le script LUA
On connecte son MCP V2 ou V3 Opencockpit sur son ordinateur.
On ouvre le fichier téléchargé sur Opencockpit et on obtient plusieurs fichiers
On va dans son FSUIPC.INI et on rajoute en haut

Code:
[Auto]
1=lua NGXEFIS_PP_202
2=lua NGXMCP_PP_202

Note : si vous utilisez seulement le MCP il faut mettre :

Code:
[Auto]
1=lua NGXMCP_PP_202

Note : si vous utilisez seulement lEFIS il faut mettre :

Code:
[Auto]
1=lua NGXEFIS_PP_202

Toujours dans FSUIPC.INI en bas de page

Code:
[LuaFiles]
1=ipcReady
2=linda
3=NGXMCP_PP_202

Note : si vous utilisez seulement lEFIS il faut mettre :

Code:
[LuaFiles]
1=ipcReady
2=linda
3=lua NGXEFIS_PP_202

Ok maintenant vous copier le fichier NGXEFIS_PP_202.lua et/ou le NGXMCP_PP_202.lua dans le dossier modules de votre FSX/P3D en fonction de ce que vous avez ajouter dans votre FSUIPC.INI ci dessus.

Note : La modification dans le SIOC.INI est Obsolète depuis la version 5.0 b5 (Autoconfig)

Ensuite vous allez dans SIOC.exe et vous allez chercher le fichier .ssi qui convient ou vous compiler 2 SSI (EFIS+MCP) en 1 fichier .SSI puis vous allez dans setup pour désigner lemplacement de ce fichier .SSI dans mon exemple le MCP et on fais RELOAD quand on a fini et on ferme SIOC.EXE.

Voila c'est fini maintenant on lance d'abord FSX/P3D puis on lance SIOC, ce n'est que lorsque le PMDG sera lancer (dans le cockpit) que le MCP s'allumera
 
Dernière édition:
Bonjour à  vous,

Chez moi ça ne marche, je ne comprends pas pourquoi, je n'arrive pas faire marcher le MCP. Et pourtant j'ai suivi à  la lettre le tuto. Mon MCP s'allume mais je ne peux pas interagir avec P3D. Jaurais besoins d'aide. En plus, j'ai été bloqué lors de la suppression des attributions pour LINDA. Je pense que j'ai du faire des bêtises. :)

Merci de maider.

Bonne fin de journée.
Cordinateuralement,
ARF7818
 
Salut ce tuto est 100% fonctionnel avec le PMDG et P3D.

Pour t'aider il me faut des screens :

Du dossier modules de FSuipc,
Du fsuipc.ini,
De SIOC avec le MCP branché
Du Sioc.ini
Du Config device
Du script SSI lua
 
Re salut, je te remercie pour laide, je t'ai préparé les photos que tu mas demandé. :)
























Voilà  Voilà  :) ça fait beaucoup de photos.

Bonne soirée à  toi et merci encore. :)

Cordinateuralement,
ARF7818
 
Ok merci, tu n'as pas suivi le tuto a la lettre puisque Linda na pas ete installer. Comment veux tu que ca marche si tu ninstalles pas linda??

Pour que ca fonctionne Il doit ressembler a ca (le lien vers le tuto Linda se trouve dans les premieres ligne de ce post, tu ne peux pas le rater)
16010410275416200213873295.jpg


Ensuite dans ton Fsuipc.INI il manque un bout de code en haut et en bas, je tinvite donc a relire soigneusement les premieres lignes du 1er post

PS : installe convenablement Linda et apres on verra pour les autres fichiers!!
 
Ne faut-il pas aussi rajouter
dans <FSX dossier racine>\PMDG\PMDG 737 NGX\737NGX_Options.ini
les lignes:
[SDK]
EnableDataBroadcast=1

afin dautoriser les communications de données du PMDG ? :D
 
Bonjour,
Alors j'ai réinstaller Linda, erreur de ma part pour mon premier post, je ne l'avais pas fait.



Et j'ai rajouté les deux lignes dans le fichier FSUIPC.ini en haut et en bas, et rien, ça ne marche toujours pas. J'ai bien le MCP qui s'allume mais je ne peux pas le faire interagir.

Juste pour vous dire que maintenant ça marche, j'ai réinstaller FSUIPC, et ça marche.
Merci pour votre aide.

Bonne journée à  vous et merci de maider. :)

Cordinateuralement,
AFR7818
 
Bonsoir Silverstar,
Merci pour ce tuto, Cela fait 2 semaines que j'ai fais cette config, et j'ai souvent le même problème depuis.
Mon mcp ne réponds pas 8/10, même en faisant "reload" sur le SIOC...
Je n'ai pas didée.
Je suis disponible si tu souhaite avoir des précisions.

Yannick66
 
Est ce que tu suis toujours le même ordre de démarrage des logiciels ou il tarrive de changer des fois?
 
Oui justement
cela ne fonctionne pas 8 fois sur 10.
le mcp s'allume, les afficheurs aussi, mais ils restent sur 000, sans action possible avec l'écran.
 
Ce soir j'ai du monde à  la maison. On en reparle un peu plus tard...
 
Je pense que ton souci doit venir de SIOC, chez moi il déconne aussi des fois.
 
Essaye de sortir ton code en txt puis de limporter voir si tes OK dans la compilation
 
yannick66 a dit:
Oui justement
cela ne fonctionne pas 8 fois sur 10.
le mcp s'allume, les afficheurs aussi, mais ils restent sur 000, sans action possible avec l'écran.

Sinon pour mieux t'aider il me faut des screens :
Du dossier modules de FSuipc,
Du fsuipc.ini,
De SIOC avec le MCP branché
Du Sioc.ini
Du Config device
Du script SSI lua
 
Retour
Haut